Bad mode when trying to run Geminus acceleration demo

For support of the Geminus screen acceleration feature
Post Reply
alanb
Posts: 3
Joined: Thu Jun 30, 2005 11:33 am

Bad mode when trying to run Geminus acceleration demo

Post by alanb » Thu Jan 05, 2006 10:04 am

I've downloaded the latest (1.20) Geminus acceleration demonstration, copied it to my hard disk and then double clicked on the GemConfig application. All I get is a message box saying "Bad Mode".
I'm using the Generic LCD driver that came with my monitor (bought from here) and I am starting it in a 1280x1024x32bpp screen mode.
I've tried to start GemConfig in other screen modes all have the same effect.
Any ideas of what is going wrong?

admin
Site Admin
Posts: 381
Joined: Wed Oct 23, 2002 11:25 pm
Location: Cambridge, England
Contact:

Post by admin » Thu Jan 05, 2006 12:11 pm

Try double-clicking the module !GemConfig.Geminus so that the module is loaded but not the user interface. If you get the same error then try moving the contents of the directory !Boot.Choices.Geminus to a safe directory (so that I can work out what's happening later).

I'd expect that to 'fix' the problem and allow you to start Geminus, but if it still fails then I'll need to look at the MDF that you're using, please. Perhaps you could upload this and the files removed from !Boot.Choices.Geminus to ftp.aemulor.com, please?

Please let me know what you discover, but note that it may be a short while before I can look at this properly. If none of the above helps, it may be worth changing your Monitor type in Configure.Screen to a different MDF temporarily to see whether Geminus is objecting to a specific mode.

alanb
Posts: 3
Joined: Thu Jun 30, 2005 11:33 am

Post by alanb » Fri Jan 06, 2006 8:31 am

It appears that it is the MDF file that causes the problem as double-clicking on the Geminus file produced the same error, but the error went away when I temporarily switched to another monitor.
I've uploaded "Config" from !Boot.Choices.Geminus and "lcdmonitor.zip" (the MDF file in a zip file) to the ftp site as requested.
Note: The MDF file is that supplied with my LCD monitor which was bought from you (Shows as Generic LCD), so if it does have a problem you probably want to update it.

alanb
Posts: 3
Joined: Thu Jun 30, 2005 11:33 am

Post by alanb » Tue Mar 28, 2006 10:43 am

Just to report that the latest Geminus demonstration (1.30) loads OK.
I assume this has been fixed by the MDF file parsing changes that have been added.

admin
Site Admin
Posts: 381
Joined: Wed Oct 23, 2002 11:25 pm
Location: Cambridge, England
Contact:

Post by admin » Tue Mar 28, 2006 4:38 pm

Yup ;)

Post Reply