Accelerating the A9home

For support of the Geminus screen acceleration feature
Post Reply
pittdj
Posts: 19
Joined: Sun Feb 23, 2003 10:51 pm

Accelerating the A9home

Post by pittdj » Sun Apr 16, 2006 12:37 pm

How does one obtain Geminus acceleration for the A9home. There is a problem finding the MAC address for this machine. The little utility on this site is obsolete as it does not have an AIF header as the A9home now requires. The answer from *exinfo did not work.

admin
Site Admin
Posts: 381
Joined: Wed Oct 23, 2002 11:25 pm
Location: Cambridge, England
Contact:

Post by admin » Sun Apr 16, 2006 8:50 pm

Good point. I've uploaded a new version here:

http://adrian.aemulor.com/downloads/rmac.zip


Neil: please copy this to the main site. Thanks.

pittdj
Posts: 19
Joined: Sun Feb 23, 2003 10:51 pm

Post by pittdj » Mon Apr 17, 2006 7:25 am

The new Readmac does run on the A9home but it returns a different answer to *exinfo. Calling OS_ReadSysInfo,2 from BASIC also comes up with what looks like a garbled mac.

The website will not accept the output from Readmac though it has accepted the result from *exinfo, but that just gives a download that thinks it is on the wrong machine.

pittdj
Posts: 19
Joined: Sun Feb 23, 2003 10:51 pm

Post by pittdj » Mon Apr 17, 2006 10:21 am

I blundered, the MAC and machine ID are not the same on the A9home, that is only the case on the Iyonix. The number required for the download is the result from the Readmac utility.

I now do have a download, the module loads but Geminus.!RunImage does not. "This application uses an obsolete executable file format which is no longer supported by RISC OS".

admin
Site Admin
Posts: 381
Joined: Wed Oct 23, 2002 11:25 pm
Location: Cambridge, England
Contact:

Post by admin » Mon Apr 17, 2006 3:03 pm

The following simple BASIC program will patch GemConfig so that it runs on the pre-release of Select 4.42 - http://adrian.aemulor.com/downloads/patcha9.zip

This change will soon be rolled into the webserver, and the above is really only intended for A9home users who have just upgraded to the latest Select 4.42 pre-release and found that GemConfig no longer starts.

pittdj
Posts: 19
Joined: Sun Feb 23, 2003 10:51 pm

Post by pittdj » Mon Apr 17, 2006 4:54 pm

Many thanks, that works, Geminus now loaded.

Post Reply